WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru Купить персональные IPV4 и IPV6 прокси
функция не описана

is_protected_ajax_action() WP 5.2.0

Determines whether we are currently handling an AJAX action that should be protected against WSODs.

Хуки из функции
Возвращает

true/false. True if the current AJAX action should be protected.

Использование

is_protected_ajax_action();

Список изменений

С версии 5.2.0 Введена.

Код is protected ajax action: wp-includes/load.php WP 5.2.2

<?php
function is_protected_ajax_action() {
	if ( ! wp_doing_ajax() ) {
		return false;
	}

	if ( ! isset( $_REQUEST['action'] ) ) {
		return false;
	}

	$actions_to_protect = array(
		'edit-theme-plugin-file', // Saving changes in the core code editor.
		'heartbeat',              // Keep the heart beating.
		'install-plugin',         // Installing a new plugin.
		'install-theme',          // Installing a new theme.
		'search-plugins',         // Searching in the list of plugins.
		'search-install-plugins', // Searching for a plugin in the plugin install screen.
		'update-plugin',          // Update an existing plugin.
		'update-theme',           // Update an existing theme.
	);

	/**
	 * Filters the array of protected AJAX actions.
	 *
	 * This filter is only fired when doing AJAX and the AJAX request has an 'action' property.
	 *
	 * @since 5.2.0
	 *
	 * @param array $actions_to_protect Array of strings with AJAX actions to protect.
	 */
	$actions_to_protect = (array) apply_filters( 'wp_protected_ajax_actions', $actions_to_protect );

	if ( ! in_array( $_REQUEST['action'], $actions_to_protect, true ) ) {
		return false;
	}

	return true;
}