WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru
функция не описана

user_can_edit_user() WP 1.5.0

Запрещена (устарела) с версии 2.0.0. Больше не поддерживается и может быть удалена. Используйте current_user_can().

Can user can edit other user.

Хуков нет.

Возвращает

true/false.

Использование

user_can_edit_user( $user_id, $other_user );
$user_id(число) (обязательный)
$other_user(число) (обязательный)

Заметки

  • Смотрите: current_user_can()

Список изменений

С версии DEL 2.0.0 Введена.

Код user can edit user: wp-includes/deprecated.php WP 5.3

<?php
function user_can_edit_user($user_id, $other_user) {
	_deprecated_function( __FUNCTION__, '2.0.0', 'current_user_can()' );

	$user  = get_userdata($user_id);
	$other = get_userdata($other_user);
	if ( $user->user_level > $other->user_level || $user->user_level > 8 || $user->ID == $other->ID )
		return true;
	else
		return false;
}