WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru
функция не описана

ACF_Compatibility::field_wrapper_attributes() public ACF 5.7.10

Adds compatibility with deprecated field wrap attributes.

{} Это метод класса: ACF_Compatibility{}

Хуков нет.

Возвращает

Null. Ничего.

Использование

$ACF_Compatibility = new ACF_Compatibility();
$ACF_Compatibility->field_wrapper_attributes( $wrapper, $field );
$wrapper(массив) (обязательный)
The wrapper attributes array.
$field(массив) (обязательный)
The field array.

Список изменений

С версии 5.7.10 Введена.

Код ACF_Compatibility::field_wrapper_attributes() ACF 5.9.1

<?php
function field_wrapper_attributes( $wrapper, $field ) {
	
	// Check compatibility setting.
	if( acf_get_compatibility('field_wrapper_class') ) {
		$wrapper['class'] .= " field_type-{$field['type']}";
		if( $field['key'] ) {
			$wrapper['class'] .= " field_key-{$field['key']}";
		}
	}
	
	// Return wrapper.
	return $wrapper;
}