WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru Получай пассивный доход от сайта с помощью браузерных PUSH уведомлений
функция не описана

Automattic\WooCommerce\Admin\Composer

Package::check_outdated_wca_plugin() public WC 1.0

Checks if embedded WCA version is newer than standalone WCA and adds/removes DeactivatePlugin note as necessary.

{} Это метод класса: Package{}

Хуков нет.

Возвращает

null. Ничего.

Использование

$result = Package::check_outdated_wca_plugin();

Код Package::check_outdated_wca_plugin() WC 5.2.2

<?php
public static function check_outdated_wca_plugin() {

	if ( ! self::is_notes_initialized() ) {
		return;
	}

	$update_version = new DeactivatePlugin();

	if ( version_compare( WC_ADMIN_VERSION_NUMBER, self::VERSION, '<' ) ) {
		if ( method_exists( $update_version, 'possibly_add_note' ) ) {
			$update_version::possibly_add_note();
		}
	} else {
		$update_version::delete_note();
	}
}