WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru Платформа для конвертации и монетизации трафика
функция не описана

Composer\Installers

SilverStripeInstaller::getInstallPath() public WC 1.0

Return the install path based on package type.

Relies on built-in BaseInstaller behaviour with one exception: silverstripe/framework must be installed to 'sapphire' and not 'framework' if the version is <3.0.0

{} Это метод класса: SilverStripeInstaller{}

Хуков нет.

Возвращает

Строку.

Использование

$SilverStripeInstaller = new SilverStripeInstaller();
$SilverStripeInstaller->getInstallPath( $package, $frameworkType );
$package(Packageчислоerface) (обязательный)
$frameworkType(строка)

По умолчанию: ''

Код SilverStripeInstaller::getInstallPath() WC 4.7.1

<?php
public function getInstallPath(PackageInterface $package, $frameworkType = '')
{
    if (
        $package->getName() == 'silverstripe/framework'
        && preg_match('/^\d+\.\d+\.\d+/', $package->getVersion())
        && version_compare($package->getVersion(), '2.999.999') < 0
    ) {
        return $this->templatePath($this->locations['module'], array('name' => 'sapphire'));
    }

    return parent::getInstallPath($package, $frameworkType);
}