WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru
функция не описана

WC_Admin_Setup_Wizard::should_show_wc_admin() protected WC 1.0

Устарела с версии 4.6.0. Больше не поддерживается и может быть удалена. Рекомендуется заменить эту функцию на аналог.

Should we show the WooCommerce Admin install option? True only if the user can install plugins, and is running the correct version of WordPress.

{} Это метод класса: WC_Admin_Setup_Wizard{}

Хуков нет.

Возвращает

true|false.

Использование

// protected - в коде основоного (родительского) или дочернего класса
$result = $this->should_show_wc_admin();

Заметки

  • Смотрите: WC_Admin_Setup_Wizard::$wc_admin_plugin_minimum_wordpress_version

Список изменений

Устарела с 4.6.0

Код WC_Admin_Setup_Wizard::should_show_wc_admin() WC 5.4.1

<?php
protected function should_show_wc_admin() {
	_deprecated_function( __CLASS__ . '::' . __FUNCTION__, '4.6.0', 'Onboarding is maintained in WooCommerce Admin.' );
	$wordpress_minimum_met = version_compare( get_bloginfo( 'version' ), $this->wc_admin_plugin_minimum_wordpress_version, '>=' );
	return current_user_can( 'install_plugins' ) && $wordpress_minimum_met && ! $this->is_wc_admin_active();
}