Yoast\WP\SEO\Services\Health_Check

Curl_Reports::get_no_recent_curl_version_installed_description()privateYoast 1.0

Returns the description for when the health check couldn't find a recent enough version of cURL installed on the server.

{} Это метод класса: Curl_Reports{}

Хуков нет.

Возвращает

Строку. The description containing a link to a Yoast help page about keeping cURL up to date.

Использование

// private - только в коде основоного (родительского) класса
$result = $this->get_no_recent_curl_version_installed_description();

Код Curl_Reports::get_no_recent_curl_version_installed_description() Yoast 19.2

private function get_no_recent_curl_version_installed_description() {
	return sprintf(
		/* translators: %1$s Emphasis open tag, %2$s: Emphasis close tag, %3$s Link start tag to the Yoast help center, %4$s Link closing tag, %5$s to Yoast SEO, %6$s to my.yoast.com. */
		esc_html__( 'You can %1$snot%2$s activate your premium plugin(s) and receive updates because %5$s cannot connect to %6$s. The cause for this error is probably that the cURL software on your server is too old. Please contact your host and ask them to update it to at least version 7.34. %3$sRead more about cURL in our help center%4$s.', 'wordpress-seo' ),
		'<em>',
		'</em>',
		'<a href="' . esc_url( $this->shortlinker->get( 'https://yoa.st/3u8' ) ) . '" target="_blank">',
		WPSEO_Admin_Utils::get_new_tab_message() . '</a>',
		'Yoast SEO',
		'my.yoast.com'
	);
}