WPSEO_Utils::is_apache()public staticYoast 1.8.0

Check if the web server is running on Apache or compatible (LiteSpeed).

{} Это метод класса: WPSEO_Utils{}

Хуков нет.

Возвращает

true|false.

Использование

$result = WPSEO_Utils::is_apache();

Список изменений

С версии 1.8.0 Введена.

Код WPSEO_Utils::is_apache() Yoast 19.7.1

public static function is_apache() {
	if ( ! isset( $_SERVER['SERVER_SOFTWARE'] ) ) {
		return false;
	}

	$software = sanitize_text_field( wp_unslash( $_SERVER['SERVER_SOFTWARE'] ) );

	return stripos( $software, 'apache' ) !== false || stripos( $software, 'litespeed' ) !== false;
}