WordPress как на ладони
Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru

Carbon Fields. Back-end. Не выводятся поля по формату записи после обновления вп

Версия ВП 5.0.3
Перестало работать условие

->where('post_format', '=', 'format')

Все поля, имеющие это условие, не выводятся в админке. От собственно формата записи не зависит. Во Front-end данные из этих полей выводятся.

Помогите, пожалуйста!

Заметки к вопросу:
campusboy 2 мес назад

Версию CF обновили? Там 3 выпущена под новый WP

Koxae 2 мес назад

Спасибо за ответ! Сейчас обновила и сломала вообще весь Front-end. Показывает пустую страницу, хотя в админке всё в полном порядке.
Я подключаю плагин как библиотеку без composer. Для обновления просто заменила файлы. Думаю, это было неверным решением, раз сайт сломался. Откат на старые файлы проблему не решает. Ситуация не критична, поскольку экспериментирую с локальным черновиком, но хотелось бы устранить ошибку.
Буду благодарна за советы и помощь! Если необходимо, создам новый вопрос.

campusboy 2 мес назад

Ничего не могу сказать, я же не прорицатель smile Недавно ставил себе CF3 (как плагин), чтобы помочь человеку тут в вопросах и не испытал никаких проблем. Мне CF3 очень напомнило CF2, я в целом даже разницы не заметил в синтаксисе. Единственное блоки для Гутенберг добавились.

Если у Вас какая-то проблема, особенно белый экран, то первое, что нужно сделать - заглянуть в логи, ведь белый экран зачастую признак 500 ошибки.

Koxae 2 мес назад

Мне стыдно, но я понятия не имею, где смотреть логи. Файла wp-content/debug-log.php у меня нет и самостоятельно он не создаётся, даже если включить отладку в файле конфигурации ВП. Все протестированные мной плагины для логов также не дали положительного результата. У страницы грузится только пустой хидер, далее всё пусто. Раздел head загружается полностью. В общем, похоже, я могу похоронить локальный сайт.

0
Koxae
2 месяца назад 6
  • 0
    campusboy3314 cайт: www.youtube.com/c/wpplus

    Мы вроде с Вами уже вели разговор насчёт дебага, разве нет? У нас есть статейка Дебаг в WordPress, просим милости.

    Koxae 2 мес назад

    Я уже вдоль и поперёк прочитала несколько руководств по дебагу в вп, пытаясь понять, что я делаю не так. Потому что я в конфиге дебаг включила, а никакой реакции не наблюдаю. Просто белая страница грузится.
    Вот кусок моего конфига

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    
    error_reporting(E_ALL);
    ini_set('display_errors', 1);
    
    ini_set('log_errors', 'On');
    ini_set('error_log', 'A:\Server\home\clown-wp/log/php-errors.log');

    Последние две строки от плагина

    Комментировать
На вопросы могут отвечать только зарегистрированные пользователи. Вход . Регистрация