WordPress как на ладони
Дешевый WordPress пакет для разработки Недорогой хостинг для сайтов на WordPress: wordpress.jino.ru

Как отключить jquery-migrate-0.5.9.js

Добрый день, Тимур!

Подскажите пожалуйста, как мне изменить версию подгружаемого в хэдере скрипта jquery-migrate-0.5.9.js ?

Дело в том, что по пути из исходного кода

http://vkusniebluda.ru/wp-includes/js/jquery-migrate-0.5.9.js

такого файла нет, но при тестировании сервисом tools.pingdom.com именно этот скрипт грузится более 10 секунд. Подключения именно этого файла я не нашла, но в header.php есть следующие строки:

function smt_register_scripts() {
	wp_deregister_script( 'jquery' );
	wp_register_script( 'jquery', 'https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js' );
	wp_enqueue_script( 'jquery' );
	wp_register_script( 'googlemaps', 'http://maps.google.com/maps/api/js?sensor=false', array( 'jquery' ), '3' );
	wp_enqueue_script( 'googlemaps' );
}
add_action('init', 'smt_register_scripts');

Думаю, что проблема здесь. Только вот не могу понять, как изменить версию подгружаемого скрипта или путь к подгружаемому скрипту, чтобы загружать другую версию.

Сайт vkusniebluda.ru

Заранее благодарю!

0
Гость
3.8 года назад
  • 0
    Kama6958

    В вашем случае не должно быть проблемы, все у вас правильно подключается за исключение возможно хука, но это тоже не страшно.

    Попробуйте изменить хук init на wp_enqueue_scripts.

    Ознакомьтесь со статьей: Подключение jQuery c CDN Google.

    П.С. Смотрю сейчас все вроде нормально у вас на сайте.

    Елена 3.8 года назад

    Тимур, спасибо за быстрый ответ!

    Комментировать
На вопросы могут отвечать только зарегистрированные пользователи. Вход . Регистрация