WordPress как на ладони
wordpress jino

Не могу подключить стили и скрипты

Уже не знаю что делать. От не получается у меня подключить скрипты правильным способом

add_action( 'wp_enqueue_scripts', 'theme_name_scripts' );
function theme_name_scripts() {
	wp_enqueue_style( 'style-name', get_stylesheet_uri() );
	wp_enqueue_script( 'script-name', get_template_directory_uri() . '/js/example.js', array(), '1.0.0', true );
}

Создал файл function.php и в нее вставил, выше указанный код.

<?php 

add_action( 'wp_enqueue_scripts', 'theme_name_scripts' );
function theme_name_scripts() {
	wp_enqueue_style( 'style-name', get_stylesheet_uri() );
	wp_enqueue_script( 'script-name', get_template_directory_uri() . '/js/example.js', array(), '1.0.0', true );
wp_enqueue_script( 'jqueryjs', get_template_directory_uri() . '/libs/jquery/jquery-1.11.2.min.js', array(), '0.1', true );
	wp_enqueue_script( 'modernizrjs', get_template_directory_uri() . '/libs/modernizr/modernizr.js', array(), '0.1' );
	wp_enqueue_script( 'bootstrapjs', get_template_directory_uri() . '/libs/bootstrap/js/bootstrap.min.js', array(), '0.1', true );
	wp_enqueue_script( 'freewalljs', get_template_directory_uri() . '/libs/freewall/freewall.js', array(), '0.1', true );
	wp_enqueue_script( 'magnificjs', get_template_directory_uri() . '/libs/magnific-popup/jquery.magnific-popup.min.js', array(), '0.1', true );
	wp_enqueue_script( 'nicescrolljs', get_template_directory_uri() . '/libs/nicescroll/jquery.nicescroll.min.js', array(), '0.1', true );
	wp_enqueue_script( 'lazyjs', get_template_directory_uri() . '/libs/lazyload/jquery.lazyload.min.js', array(), '0.1', true );

	wp_enqueue_script( 'commonjs', get_template_directory_uri() . '/js/common.js', array(), '0.1', true );
}

?>
<?php wp_head(); ?>

В итоге получилось такое.

В браузере всё равно нет моих скриптов

<head>
	<meta charset="utf-8">

	<title>Заголовок</title>
	<meta content="" name="description">

	<link rel="shortcut icon" href="img/favicon/favicon.ico" type="image/x-icon">
	<link rel="apple-touch-icon" href="img/favicon/apple-touch-icon.png">
	<link rel="apple-touch-icon" sizes="72x72" href="img/favicon/apple-touch-icon-72x72.png">
	<link rel="apple-touch-icon" sizes="114x114" href="img/favicon/apple-touch-icon-114x114.png">

	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

	<!--<link rel="stylesheet" href="css/fotns.css" />
	<link rel="stylesheet" href="css/main.css" />!-->
	<link rel="stylesheet" href="http://sity.ru/wp-content/themes/SethollmeThemes/style.css">

</head>

И со стилями беда, всё такая же, только метод

<link rel="stylesheet" href="<?php bloginfo ('stylesheet_url') ?>" >

сработал. Подскажите, что неверно делаю? Уже и видео посмотрел, наверное есть ошибка, а где не знаю.

0
Гость 9 месяцев назад
  • 0

    в functions.php не нужно вставлять

    <?php wp_head(); ?>

    в шаблоне нужно вписать

    <?php wp_header(); ?> и 
    <?php wp_footer(); ?>

    и в header.php вставляешь

    <head><?php wp_head(); ?></head>
    sergiyss 9 месяцев назад

    Дело в том что нечего не получается.

    <?php wp_header(); ?>  
    <?php wp_footer(); ?>

    Выдает ошибку. Изменил на

    <?php get_header(); ?> и 
    <?php get_footer(); ?>

    В header.php, как вы сказали вставил код. Нечего((

    sergiyss 9 месяцев назад

    Но было чудо, заработал мой скрипт, потом всё сломалось, я заново создал тему, всё распихал и опять нечего не работает((

    sergiyss 9 месяцев назад

    файл functions.php присутствует в консоле WP

    sergiyss 9 месяцев назад

    Скрипт даже не работает когда указал точный путь к файлу. От что отображается в браузере

    <script href="http://set-holl/wp-content/themes/themeforr/common.js"></script>

    От какой код я задействовал

    <script href="<?php bloginfo('template_directory'); ?>/common.js"></script>

    Может дело в ПК или Open server?

    Комментировать
На вопросы могут отвечать только зарегистрированные пользователи. Регистрация. Вход.