WordPress как на ладони
Шаблоны, плагины и темы для настоящих поклонников Elementor. От TemplateMonster.com wordpress jino

Прописывается абсолютный путь к картинкам в kama-thumbnail

Добрый день! сайт переехал на новый сервер, теперь картинки создаются, но не везде отображаются, так как почему-то в путь к картинке прописывается вот так:

http://site.org/home/mydoccxh/public_html/wp-content/cache/thumb/5967c0289_285x196

т.е к пути  добавляется абсолютный путь. КАРТИНКИ ОТОБРАЖАЮТСЯ НЕ ВСЕ. Пробовал играться с путями и ставил разные настроки, оставлял просто /wp-content/cache/thumb - тоже не работает корректно

Вот настройки путей:

Помогите разобраться, голова пухнет. Тем более, я не один такой. В комментариях встречались товарищи по беде

РЕШЕНИЕ ПРОБЛЕМЫ

Короче костыль, но проблема решена. Итак:

в head повесил

<base href="http://my-doc.org/" />

путь в настройках прописал ./wp-content/cache/thumb

Заметки к вопросу:
seredniy 3 года назад

http://searchengines.guru/showthread.php?t=904171

Тут расписал более детально и свежо

Kama 3 года назад

Зайдите в редактирование записи, где картинка не отображается и посмотрите там в произвольном поле, какая ссылка сохранена?

Попробуйте удалить все произвольные поля через ссылку в настройках плагина и очистите кэш там же на всякий случай.

Если ничего не помогает, то буду думать. Любые дополнительные заметки могут пригодится, даже самые странные...

seredniy 3 года назад

редактировал записи, удалял поля, изменял имя поля и т.д. Тишина... В произвольном поле БЫЛА сохранена ссылка на полноценную картинку (оригинал).

Сейчас произвольное поле вообще не активно как бы...т.е. вот так выглядит:

http://dl1.joxi.net/drive/0003/0525/238093/150723/0827537c4b.png

Интересно было то, что изначально показывалась лишь часть картинок, при этом очень часто либо все картинки категории, либо ни одной. Но были и исключения, где в категории лишь 1 картинка работала.

seredniy 3 года назад

опять-таки, важно то, что путь неверный отдает, почему-то абсолютный лупит...

Kama 3 года назад

Мне чтобы поправить эту ситуацию, нужно смоделировать ситуацию и время - у меня ни того ни другого smile

1
3 года назад
  • 1
    campusboy2987 cайт: www.youtube.com/c/wpplus

    У меня так было. Плагин я не использовал, но похожие файлы были. Я просто через тотал командер загружал. Потом установил ФайлЗиллу, поставил галочку "Загружать принудительно в UTF-8" и проблема пропала wink

    Скриншот установки функции http://i.imgur.com/3ZK5Qrf.png
    Попробуй этот вариант хотя бы на 1 файле, а там уже дальше можно будет думать, что делать.

    seredniy 3 года назад

    емм) а причем тут кодировка?

    Я пока понял только то, что плагин неверно отдает путь к картинке, он должен быть:

    wp-content/cache/thumb/sdaw322_285x196.png а не

    http://site.org/home/mydoccxh/public_html/wp-content/cache/thumb/5967c0289_285x196

    campusboy 3 года назад

    Просто после перезаливки на другой хост знак x может по другому "читатья". Вобщем, я рассказал, с чем сам столкнулся. Пути правил? Я вижу вон у него в настройках путь до кеша указывается. Он верно сейчас выставлен?

    seredniy 3 года назад

    я проблему решил) спасибо! Обновил вопрос, там написал как решился

    campusboy 3 года назад

    Эх, тоже хотелось "помучаться". Но хорошо, что решилось. Кстати, Тимур правильные советы дал, стоит прислушаться. Просто абы как в PHP не бывает - это математика, а значит всё решаемо))

    Комментировать
На вопросы могут отвечать только зарегистрированные пользователи. Вход . Регистрация