WordPress как на ладони

Не работают стили плагинов

Пишу свою тему на Вордпрессе. Сейчас выскочила проблема. При установке любого плагина, Вордпресс не видит стилей этого плагина. (В других темах такой проблемы нет). Если добавить все руками, все нормально. Но иногда css файлов целая куча и это не совсем удобно.

Судя по всему, где-то стер или не дописал строчку кода (которая автоматом прописывает стиль плагина)

Вопрос: где и что надо прописать?

0
Гость
6.3 года назад
  • 0
    stepan2273 www.weblancer.net/users/stepanko/?affili...

    Скорее всего забыли прописать в файле header.php функцию:

    <?php wp_head(); ?>
    Гость 6.3 года назад

    Нет. Эта строчка присутствует

    stepan 6.3 года назад

    Тогда нужно только код смотреть. По другому никак.

    stepan 6.3 года назад

    Как вариант еще: включите режим DEBAG

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', true); // можно ставить и false, но не забывайте тогда смотреть в файл debug.log

    разместить код в wp-config.php

    BART_VIVA 5 месяцев назад

    столкнулся с этой же проблемой, как оказалось в файле темы functions.php нужно было включить jquery
    было:

    wp_deregister_script( 'jquery' , 'https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js' );

    стало:

    wp_enqueue_script( 'jquery' , 'https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js' );

    после чего у меня все прекрасно заработало.

    P.S. - в начале все таки проверьте подключен ли хедер и футер, как писал выше Степан

    Комментировать
На вопросы могут отвечать только зарегистрированные пользователи. Вход . Регистрация